博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
HDU3870- intervals(差分约束)
阅读量:5313 次
发布时间:2019-06-14

本文共 1989 字,大约阅读时间需要 6 分钟。

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. 

Write a program that: 
> reads the number of intervals, their endpoints and integers c1, ..., cn from the standard input, 
> computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i = 1, 2, ..., n, 
> writes the answer to the standard output 

Input

The first line of the input contains an integer n (1 <= n <= 50 000) - the number of intervals. The following n lines describe the intervals. The i+1-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50 000 and 1 <= ci <= bi - ai + 1. 

Process to the end of file. 
 

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i = 1, 2, ..., n. 

Sample Input

53 7 38 10 36 8 11 3 110 11 1

Sample Output

6

这是一个差分约束的基础题;

求最长路即可;

AC代码为:

//scanf,printf过了。cin cout T了Orz 

#include<bits/stdc++.h>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=1e5+10;
int n,tot,S,T,u,v,w;
int dis[maxn],first[maxn],vis[maxn];
struct Node{
    int v,w,net;
} edge[maxn*10];

void addedge(int u,int v,int w)

{
    edge[tot].v=v;
    edge[tot].w=w;
    edge[tot].net=first[u];
    first[u]=tot++;
}

void SPFA(int s)

{
    queue<int> q;
    memset(dis,-INF,sizeof dis);
    memset(vis,0,sizeof vis);
    q.push(s); dis[s]=0;
    while(!q.empty())
    {
        int u=q.front(); q.pop();
        vis[u]=0;
        for(int i=first[u];~i;i=edge[i].net)
        {
            if(dis[edge[i].v]<dis[u]+edge[i].w) 
            {
                dis[edge[i].v]=dis[u]+edge[i].w;
                if(!vis[edge[i].v])
                {
                    vis[edge[i].v]=1;
                    q.push(edge[i].v);  
                }   
            }
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        tot=1, S=INF,T=-INF;
        memset(first,-1,sizeof first);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            S=min(S,u-1),T=max(T,v);
            addedge(u-1,v,w);
        }
        for(int i=S;i<T;i++)
        {
            addedge(i,i+1,0);
            addedge(i+1,i,-1);
        }
        SPFA(S);
        printf("%d\n",dis[T]);
    }
    
    
    return 0;   

转载于:https://www.cnblogs.com/songorz/p/9386777.html

你可能感兴趣的文章
面向对象(多异常的声明与处理)
查看>>
MTK笔记
查看>>
ERROR: duplicate key value violates unique constraint "xxx"
查看>>
激活office 365 的启动文件
查看>>
9款免费的Windows远程协助软件
查看>>
Maven(八) Maven项目和testng结合应用
查看>>
iOS 的 set.get.构造方法
查看>>
无法根据中文查找
查看>>
文件编码,文件或文件名编码格式转换(转)
查看>>
[简讯]phpMyAdmin项目已迁移至GitHub
查看>>
转载 python多重继承C3算法
查看>>
【题解】 bzoj1597: [Usaco2008 Mar]土地购买 (动态规划+斜率优化)
查看>>
css文本溢出显示省略号
查看>>
git安装和简单配置
查看>>
面向对象:反射,双下方法
查看>>
鼠标悬停提示文本消息最简单的做法
查看>>
Java面向对象重要关键字
查看>>
课后作业-阅读任务-阅读提问-2
查看>>
面向对象设计中private,public,protected的访问控制原则及静态代码块的初始化顺序...
查看>>
fat32转ntfs ,Win7系统提示对于目标文件系统文件过大解决教程
查看>>